cisco_switch_stack_pic0

Дано
  • Три коммутатора Cisco WS-C2960XR-48
  • Три стек модуля с кабелями



Подключение
  • Подключаем коммутаторы стековыми кабелями. Первый порт SW1 ко второму порту SW2, первый порт SW2 ко второму порту SW3, первый порт SW3 ко второму порту SW1.
  • Подключаем шнуры питания, ждем пока загрузятся.
  • Подключаемся к коммутатору консольным кабелем.
Настройка
  • Заходим на консоль коммутатора и проверям стек:
show switch detail

Можно проверить скорость подключения:

show switch stack-ring speed

В стеке есть один master (главный), остальные — member. Критерий выбора мастера ниже (в порядке убывания):

  • свитч уже является мастером
  • свитч с наибольшим приоритетом (приоритет бывает от 1 до 15)
  • свитч имеет не дефолтную конфигурацию интерфейса
  • свитч имеет наивысший приоритет по Hardware/Software (ниже приоритеты в порядке убывания, оставлю без перевода, что бы был понятен смысл):
  • Cryptographic IP services image software
  • Noncryptographic IP services image software
  • Cryptographic IP base image software
  • Noncryptographic IP base image software
  • свитч с наибольшим аптаймом
  • свитч с наименьшим MAC-адресом

Мастер назначается автоматический в соответствии с выше перечисленными критериями, но можно выставить приоритет в ручную:

switch 1 priority 15

После объединения в стек, зайти по сети можно будет только на master коммутатор и производить все конфигурации портов только на нём. member коммутаторами можно управлять только через консольный порт.

Теперь можно настроить диапозоны портов:

!
interface range GigabitEthernet1/0/1-48
description ---Workstations and Voice---
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 30
!
interface range GigabitEthernet2/0/1-48
description ---Workstations and Voice---
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 30
!
interface range GigabitEthernet3/0/1-48
description ---Workstations and Voice---
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 30
!

Ссылки